GNU.WIKI: The GNU/Linux Knowledge Base

  [HOME] [PHP Manual] [HowTo] [ABS] [MAN1] [MAN2] [MAN3] [MAN4] [MAN5] [MAN6] [MAN7] [MAN8] [MAN9]

  [0-9] [Aa] [Bb] [Cc] [Dd] [Ee] [Ff] [Gg] [Hh] [Ii] [Jj] [Kk] [Ll] [Mm] [Nn] [Oo] [Pp] [Qq] [Rr] [Ss] [Tt] [Uu] [Vv] [Ww] [Xx] [Yy] [Zz]


NAME

       IXP_API, IXP_NEEDAPI, IXP_MAXAPI, IXP_ASSERT_VERSION

SYNOPSIS

       #include <ixp.h>

       #define IXP_API ...

       #define IXP_NEEDAPI ...

       #define IXP_MAXAPI ...

       #define IXP_ASSERT_VERSION ...

DESCRIPTION

       IXP_API contains the current libixp API revision number.

       IXP_NEEDAPI, if defined before ixp.h is included, directs the header to
       present an older version of the libixp API. This  allows  code  written
       for  older versions of libixp to compile against newer versions without
       modification. It does not, however, ensure that it will link against  a
       different version of libixp than the ixp.h header belongs to.

       IXP_MAXAPI,  if  defined  before  ixp.h is included, prevents code from
       compiling with a newer version of libixp than specified.

       When inserted into any function, IXP_ASSERT_VERSION  ensures  that  the
       resulting  object  will fail to link link against any version of libixp
       with a different API version than it was compiled against.



  All copyrights belong to their respective owners. Other content (c) 2014-2018, GNU.WIKI. Please report site errors to webmaster@gnu.wiki.
Page load time: 0.108 seconds. Last modified: November 04 2018 12:49:43.